Recent user activities on Throttled Pro

  • Gu
    Guest Upvoted a comment on Throttled Pro
    from the developer's website: "Requirements Mac OS X 10.4.x - 10.8.x **Mavericks (10.9), Yosemite (10.10) and El Capitan (10.11) are not supported.**" (bold by me) Should be posted on the Throttled Pro alternativeto page, please. kind regards tchirgnut
    Show more
    almost 3 years ago
  • jasonhancn added Throttled Pro as alternative(s) to TrafficMonitor
    almost 3 years ago
  • Tim_B added Throttled Pro as alternative(s) to TMeter
    almost 4 years ago